Witaj Gościu, jeżeli to czytasz to znaczy że nie jesteś zarejestrowany/zalogowany. Kliknij by się zarejestrować. Rejestracja zajmie mniej niż 30 sekund , a dzięki temu zniknie Ci ten dymek oraz będziesz miał pełne możliwośći personalizacji forum do własnych potrzeb.
Problem z Qt
Pokaż wyniki od 1 do 5 z 5

Temat: Problem z Qt

  1. #1
    Dołączył
    Jul 2003
    Skąd
    z Jarocina
    Postów
    21
    Wątków
    1
    Downloads
    2
    Uploads
    0
    Siła Reputacji
    0
    Reputacja
    1

    Problem z Qt

    Próbowalem compilować programy korzystające z bibliotek Qt, ale zawsze po ./configure wychodzi cos takiego:
    configure:20822: checking for Qt
    configure: 20889: /us/lib/qt/lib/qstyle.h
    configure: 20889: /usr/lib/qt3/include/qstyle.h
    configure: 20889: /usr/lib/qt3/qstyle.h
    configure: 20889: /usr/lib/qt/include/qstyle.h
    configure: 20889: /usr/lib/qt/qstyle.h
    configure: 20889: /usr/local/qt/include/qstyle.h
    configure: 20889: /usr/include/qt/qstyle.h
    configure: 20889: /usr/include/qstyle.h
    configure: 20889: /usr/X11R6/include/X11/qt/qstyle.h
    configure: 20889: /usr/X11R6/include/qt/qstyle.h
    configure: 20889: /usr/X11R6/include/qt2/qstyle.h
    configure: 20889: /usr/X11R6/include/qstyle.h
    configure:20999: rm -rf SunWS_cache; g++ -o conftest -Wnon-virtual-dtor -Wno-long-long -Wbad-function-cast -Wundef -Wall -pedantic -W -Wpointer-arith -Wmissing-prototypes -Wwrite-strings -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -O2 -fno-exceptions -fno-check-new -INO -I/usr/X11R6/include -DQT_THREAD_SUPPORT -D_REENTRANT -L/usr/lib/qt3/lib/libqt-mt.so.3.0.5 -L/usr/X11R6/lib conftest.cc -lqt-mt -lpng -lz -lm -ljpeg -ldl -lXext -lX11 -lSM -lICE -lresolv -lpthread 1>&5
    conftest.cc:2:21: qglobal.h: No such file or directory
    conftest.cc:3:26: qapplication.h: No such file or directory
    conftest.cc:4:21: qcursor.h: No such file or directory
    conftest.cc:5:27: qstylefactory.h: No such file or directory
    conftest.cc:6:34: private/qucomextra_p.h: No such file or directory
    conftest.cc:7:8: warning: "QT_VERSION" is not defined
    conftest.cc:8:2: #error 1
    conftest.cc: In function `int main()':
    conftest.cc:12: `QStyleFactory' undeclared (first use this function)
    conftest.cc:12: (Each undeclared identifier is reported only once for each function it appears in.)
    conftest.cc:12: parse error before `::' token
    conftest.cc:13: `QCursor' undeclared (first use this function)
    configure:21002: $? = 1
    configure: failed program was:
    #include "confdefs.h"
    #include <qglobal.h>
    #include <qapplication.h>
    #include <qcursor.h>
    #include <qstylefactory.h>
    #include <private/qucomextra_p.h>
    #if ! (QT_VERSION >= 303)
    #error 1
    #endif

    int main() {
    (void)QStyleFactory::create(QString::null);
    QCursor c(Qt::WhatsThisCursor);
    return 0;
    }
    configure:21042: error: Qt (>= Qt 3.0.3) (headers and libraries) not found. Please check your installation!
    For more details about this problem, look at the end of config.log.

    Próbowałem różnychopcji (--with-qt-dir=, with-qt-libraries= itp.), ale zawsze kończy sie to tak samo. Dodam, że mam zainstalowane biblioteki qt w wersji 3.0.5 łącznie z tymi dla programistów. A teraz pytanie: jak to zrobić żeby skrpt instalacyjny przestał się o nie pluć?
    Ponoć czescy naukowcy wynaleźli teleporter...
    http://hajkju.pl

  2. Panna Google
    Panna Google jest aktywna
    Avatar Panny Google

    Dołączył
    01-05-2004
    Skąd
    Internet
    Postów
    999
    Pochwał
    159

    Nie lubisz reklam? Zarejestrowani ich nie widzą! Rejestracja





  3. #2
    Dołączył
    Jul 2003
    Skąd
    Poznań
    Wiek
    34
    Postów
    1,740
    Wątków
    58
    Downloads
    0
    Uploads
    0
    Siła Reputacji
    41
    Reputacja
    141
    Możesz jeszcze spróbować skompilować program jako root (su). Z tego co pamiętam, root "widzi" więcej folderów.
    This is your life and it's ending one minute at a time.

  4. #3
    Avatar Anonymous
    Anonymous Gość
    Próbowałem i lipa, czy moznapozmieniac jakoś skrypt cofigure, żeby szukał tych bibliotek, które mam zainstalowane? A może ściągnąć sobie wersję cvs i spróbowac z nią? (tak przy okazji - jak sie do tego zabrać?)

  5. #4
    Avatar Druciak
    Druciak jest nieaktywny Gold Member
    • Platforma sprzętowa
      • Płyta Główna:
      • Abit BX-133RAID
      • Procesor:
      • Pentium III (Coppermine)
      • Karta Graficzna:
      • GeForce
      • Karta Dźwiękowa:
      • Creative Labs SB Live!
      • Monitor:
      • iiyama
      • Kernel:
      • 2.6.16.23-1
    Dystrybucja: 2.0 PLD Linux (Ac)
    Dołączył
    May 2003
    Skąd
    Warszawa
    Postów
    1,537
    Wątków
    48
    Downloads
    0
    Uploads
    0
    Siła Reputacji
    37
    Reputacja
    71
    Próbowałem i lipa, czy moznapozmieniac jakoś skrypt cofigure, żeby szukał tych bibliotek, które mam zainstalowane? A może ściągnąć sobie wersję cvs i spróbowac z nią? (tak przy okazji - jak sie do tego zabrać?)
    Wiem, ze to nie rozwiazanie, ale czasami jak probowalem skompilowac jakis program to napotykalem na rozne problemy. Ale jak zaczelem szukac rpm w roznych wyszukiwarkach, to czesto okazywalo sie, ze taki pakiet juz jest, wiec moze nie trzeba samemu kombinowac. No ale to taka moja mala propozycja.





  6. #5
    Dołączył
    Feb 2004
    Skąd
    Z pokoju
    Postów
    390
    Wątków
    36
    Downloads
    0
    Uploads
    0
    Siła Reputacji
    28
    Reputacja
    1
    widze, ze stary temat. Podobny problem mam przy instalacji apollona (po ./configure)
    Kod:
    checking for Qt... configure: error: Qt (>= Qt 3.1 (20021021)) (headers and libraries) not found. Please check your installation!
    
    For more details about this problem, look at the end of config.log.
    troche nie rozumiem tego... Co mam zrobic?

Informacje o wątku

Users Browsing this Thread

Aktualnie 1 użytkownik(ów) przegląda ten wątek. (0 zarejestrowany(ch) oraz 1 gości)

Podobne wątki

  1. Problem Z Instalacja Mandrake 9.2 10.0
    By sYn[D]rOm in forum Instalacja Mandriva
    Odpowiedzi: 2
    Ostatni post / autor: 04.04.2005, 08:33
  2. Problem Z Dzwiękiem:
    By gottogo in forum Sprzęt
    Odpowiedzi: 15
    Ostatni post / autor: 10.03.2005, 08:58
  3. Problem Przy Ladowaniu Systemu
    By Aurela in forum Instalacja Mandriva
    Odpowiedzi: 5
    Ostatni post / autor: 13.02.2005, 20:16
  4. Odpowiedzi: 7
    Ostatni post / autor: 10.05.2004, 22:35

Uprawnienia

  • Nie możesz zakładać nowych wątków
  • Nie możesz pisać wiadomości
  • Nie możesz dodawać załączników
  • Nie możesz edytować swoich postów
  •