Witaj Gościu, jeżeli to czytasz to znaczy że nie jesteś zarejestrowany/zalogowany. Kliknij by się zarejestrować. Rejestracja zajmie mniej niż 30 sekund , a dzięki temu zniknie Ci ten dymek oraz będziesz miał pełne możliwośći personalizacji forum do własnych potrzeb.
Nieprawidłowy fullscreen w xawtv
Pokaż wyniki od 1 do 9 z 9

Temat: Nieprawidłowy fullscreen w xawtv

  1. #1
    Avatar suncez
    suncez jest nieaktywny Super Moderator
    Mężczyzna
    Dystrybucja: Debian Mandriva
    Dołączył
    Aug 2004
    Postów
    3,195
    Wątków
    142
    Downloads
    11
    Uploads
    0
    Siła Reputacji
    281
    Reputacja
    3732

    Nieprawidłowy fullscreen w xawtv

    Witam!

    Już nie pierwszy raz przeszukuję sieć i podręczniki dla rozwiązania problemu z fullscreen w xawtv. Sytuacja zdarza się od lat, nie tylko u mnie i chyba nikt nie znalazł skutecznej metody. Problem pojawia się niezależnie od dystrybucji, wersji xorg czy xawtv. U mnie najczęściej występował w Mandrivie, ale teraz dopadł Debiana.

    Debian Lenny 5.0
    kernel 2.6.26-1
    xorg 11.0
    xawtv 3.99
    karta TV na bt878
    karta grafiki FX5500

    Zanim jeszcze zainstaluję sterowniki do grafiki fullscreen w xawtv działa bez kłopotu w rozdzielczości w jakiej pracuje zwykle monitor tj. 1280x1024. Po instalacji sterowników obraz z TV w trybie pełnoekranowym jest mały i otoczony czarnym obramowaniem.

    W innych programach np. mplayer (film), tvtime (telewizja) fullscreen jest w porządku. W konfiguracji xawtv ustawiony mam overlay. Tak wygląda uruchomienie z konsoli (z i bez akceleracji)
    Kod:
    suncez@aisa:~$ xawtv
    This is xawtv-3.95.dfsg.1, running on Linux/i686 (2.6.26-1-686)
    xinerama 0: 1280x1024+0+0
    Najczęstszym tłumaczeniem takiego zachowania programu jest to, że obraz telewizyjny ma określoną, niską rozdzielczość i nie udaje się go powiększyć. Aby obejść problem sugerowane jest zamiana overlay na grabdisplay - ale obraz wtedy traci u mnie na jakości i zresztą w xawtv to nie działa oraz ustawienie w konfiguracji xawtv fullscreen na 640x480 - u mnie obraz jest przesunięty, przemieszcza się za myszką i potrafi się zwiesić. Podmieniałem xorg.conf na ten z Etcha i nic.

    Do tej pory radziłem sobie zmieniając wersję sterowników nvidii, problem magicznie znikał, tyle, że teraz mam ograniczone pole manewru nowszych sterowników do mojej karty nie ma, a starsze nie chcą się instalować.

    W Debianie Etch używam sterowników 100.14.23, inne których używałem z powodzeniem to 8178, 9636.

    W Lennym przetestowałem legacy 96.43.07, łatane 100.14.19, 173.14.09, 173.14.15
    Dla 100.14.23 chwilowo nie szukałem łatki.

    Temat dokładnie o moim problemie znalazłem także na forum nvidii, ale bez rozwiązania. Wygląda jakby nie było mocnych. Ma ktoś pojęcie o co może w tym wszystkim chodzić?
    Ostatnio edytowane przez suncez ; 23.02.2009 o 06:38
    Regulamin Forum - lektura obowiązkowa Pytania - jak mądrze je zadawać vbcode - jak formatować tekst w postach Reputacja - jak używać przycisków reputacji

  2. Panna Google
    Panna Google jest aktywna
    Avatar Panny Google

    Dołączył
    01-05-2004
    Skąd
    Internet
    Postów
    999
    Pochwał
    159

    Nie lubisz reklam? Zarejestrowani ich nie widzą! Rejestracja





  3. #2
    Avatar mr_x
    mr_x jest nieaktywny Super Moderator
    Mężczyzna
    • Platforma sprzętowa
      • Płyta Główna:
      • Asus M2N-SLI
      • Procesor:
      • AMD Athlon 64 X2 5000+
      • Karta Graficzna:
      • NV GF 9800 GTX+
      • Karta Dźwiękowa:
      • Integra
      • Monitor:
      • LG 24 cale (1920x1200)
    Dystrybucja: Mint (amd64)
    Polska
    Dołączył
    Oct 2006
    Skąd
    Białystok
    Wiek
    31
    Postów
    2,572
    Wątków
    135
    Downloads
    1
    Uploads
    0
    Siła Reputacji
    636
    Reputacja
    9135

    Odp: Nieprawidłowy fullscreen w xawtv

    A tak właściwie co się działo przy próbie instalacji sterownika 100.14.23?

  4. #3
    Dołączył
    Mar 2007
    Wiek
    56
    Postów
    1,205
    Wątków
    104
    Downloads
    3
    Uploads
    0
    Siła Reputacji
    154
    Reputacja
    1950

    Odp: Nieprawidłowy fullscreen w xawtv

    A więc tak, ja mam kartę tv i kamerkę 5Mpix. Kamerka wyswietla idealny obraz panoramiczny na full screen 19" a karta TV oczywiście 768x576 czyli PAL (mogłem o parę pixeli się pomylić) Ani kamerka, ani karta TV nie potrafią pracować w trybie overlay tylko grabdisplay. Kiedyś w starej karcie i na starym Xorg to chodziło na full, teraz niestety nie, ale przyznam się nic nie kombinowałem, zobaczę co się da zrobić. Bi niby dlaczego kamerka ma działać a karta nie? ....Jan
    Nagradzam firmy produkujące sprzęt zgodny z Mandriva Linuks

    Dźwięk zawodowców Mandriva-linux-Xfce4-One-2009

  5. #4
    Avatar suncez
    suncez jest nieaktywny Super Moderator
    Mężczyzna
    Dystrybucja: Debian Mandriva
    Dołączył
    Aug 2004
    Postów
    3,195
    Wątków
    142
    Downloads
    11
    Uploads
    0
    Siła Reputacji
    281
    Reputacja
    3732

    Odp: Nieprawidłowy fullscreen w xawtv

    Jan działaj, działaj! Liczę na Ciebie Teraz tak, poniżej część logu z instalacji sterowników 100.14.23
    Kod:
    In file included from include/linux/list.h:6,
                        from include/linux/preempt.h:11,
                        from include/linux/spinlock.h:49,
                        from include/linux/seqlock.h:29,
                        from include/linux/time.h:8,
                        from include/linux/timex.h:57,
                        from include/linux/sched.h:54,
                        from include/linux/utsname.h:35,
                        from /tmp/selfgz5924/NVIDIA-Linux-x86-100.14.23-pkg1/usr/sr
       c/nv/nv-linux.h:19,
                        from /tmp/selfgz5924/NVIDIA-Linux-x86-100.14.23-pkg1/usr/sr
       c/nv/nv.c:14:
       include/linux/prefetch.h: In function ‘prefetch_range’:
       include/linux/prefetch.h:57: warning: pointer of type ‘void *’ used in a
       rithmetic
       In file included from include/asm/dma-mapping.h:9,
                        from include/linux/dma-mapping.h:52,
                        from include/asm-generic/pci-dma-compat.h:7,
                        from include/asm/pci.h:92,
                        from include/linux/pci.h:948,
                        from /tmp/selfgz5924/NVIDIA-Linux-x86-100.14.23-pkg1/usr/sr
       c/nv/nv-linux.h:78,
                        from /tmp/selfgz5924/NVIDIA-Linux-x86-100.14.23-pkg1/usr/sr
       c/nv/nv.c:14:
       include/linux/scatterlist.h: In function ‘sg_virt’:
       include/linux/scatterlist.h:199: warning: pointer of type ‘void *’ used 
       in arithmetic
       In file included from /tmp/selfgz5924/NVIDIA-Linux-x86-100.14.23-pkg1/usr/sr
       c/nv/nv-linux.h:100,
                        from /tmp/selfgz5924/NVIDIA-Linux-x86-100.14.23-pkg1/usr/sr
       c/nv/nv.c:14:
       include/linux/highmem.h: In function ‘zero_user_segments’:
       include/linux/highmem.h:134: warning: pointer of type ‘void *’ used in a
       rithmetic
       include/linux/highmem.h:134: warning: pointer of type ‘void *’ used in a
       rithmetic
       include/linux/highmem.h:134: warning: pointer of type ‘void *’ used in a
       rithmetic
       include/linux/highmem.h:134: warning: pointer of type ‘void *’ used in a
       rithmetic
       include/linux/highmem.h:137: warning: pointer of type ‘void *’ used in a
       rithmetic
       include/linux/highmem.h:137: warning: pointer of type ‘void *’ used in a
       rithmetic
       include/linux/highmem.h:137: warning: pointer of type ‘void *’ used in a
       rithmetic
       include/linux/highmem.h:137: warning: pointer of type ‘void *’ used in a
       rithmetic
       /tmp/selfgz5924/NVIDIA-Linux-x86-100.14.23-pkg1/usr/src/nv/nv.c: In function
       ‘nvos_proc_create’:
       /tmp/selfgz5924/NVIDIA-Linux-x86-100.14.23-pkg1/usr/src/nv/nv.c:630: error: 
       ‘proc_root_driver’ undeclared (first use in this function)
       /tmp/selfgz5924/NVIDIA-Linux-x86-100.14.23-pkg1/usr/src/nv/nv.c:630: error: 
       (Each undeclared identifier is reported only once
       /tmp/selfgz5924/NVIDIA-Linux-x86-100.14.23-pkg1/usr/src/nv/nv.c:630: error: 
       for each function it appears in.)
       /tmp/selfgz5924/NVIDIA-Linux-x86-100.14.23-pkg1/usr/src/nv/nv.c: In function
       ‘nv_kern_vma_nopage’:
       /tmp/selfgz5924/NVIDIA-Linux-x86-100.14.23-pkg1/usr/src/nv/nv.c:1832: error:
       ‘NOPAGE_SIGBUS’ undeclared (first use in this function)
       /tmp/selfgz5924/NVIDIA-Linux-x86-100.14.23-pkg1/usr/src/nv/nv.c: At top leve
       l:
       /tmp/selfgz5924/NVIDIA-Linux-x86-100.14.23-pkg1/usr/src/nv/nv.c:1839: error:
       unknown field ‘nopage’ specified in initializer
       /tmp/selfgz5924/NVIDIA-Linux-x86-100.14.23-pkg1/usr/src/nv/nv.c:1839: warnin
       g: initialization from incompatible pointer type
       make[3]: *** [/tmp/selfgz5924/NVIDIA-Linux-x86-100.14.23-pkg1/usr/src/nv/nv.
       o] Błąd 1
       make[2]: *** [_module_/tmp/selfgz5924/NVIDIA-Linux-x86-100.14.23-pkg1/usr/sr
       c/nv] Błąd 2
       NVIDIA: left KBUILD.
       nvidia.ko failed to build!
       make[1]: *** [module] Błąd 1
       make: *** [module] Błąd 2
    -> Error.
    ERROR: Unable to build the NVIDIA kernel module.
    ERROR: Installation has failed.  Please see the file
           '/var/log/nvidia-installer.log' for details.  You may find suggestions
           on fixing installation problems in the README available on the Linux
           driver download page at www.nvidia.com.
    Nałożyłem na nie tą samą łatkę co na 100.14.19 i stery się zainstalowały. Niestety dalej nie ma prawdziwego fullscreen. Przerobiłem chyba wszystkie opcje z nvidia-xconfig i nic.
    Nie mam pojęcia o co biega.

    Dopisane
    W Etchu xawtv chodzi w trybie overlay, grabdisplay nie działa. Przy próbowaniu róznych opcji w xorg.conf udało mi się za pomocą nvidia-xconfig --no-overlay umożliwić xawtv pracę z grabdisplay, ale obraz mam wtedy "chwiejny".
    Dopisane
    Zrobiłem pewne odkrycie. Zwykle używam w mplayer wyjścia gl, ale w Lennym sobie eksperymentuje i ustawiłem xv - pełny fullscreen, następnie dałem x11 - tu przy fulscreen efekt taki sam jak w xawtv... dziwne, jeszcze raz zajrzałem do man xawtv i znalazłem
    Kod:
           Xvideo X11 Extension for video devices.  Note that the Xvideo extension
                  does  support  overlay  only, you can’t capture images/movies if
                  the Xvideo extension is used.  On the other  hand  this  is  the
                  only  way to scaled video overlay (i.e. fullscreen without black
                  borders @ 1024x748) if both hardware and xfree86 driver  support
                  it.   See  README.xfree4  for  more  details and hints on how to
                  setup Xvideo.
    Będę podążał tą drogą, zobaczymy. Tylko Xvideo to w mplayer wyjście xv czy X11, bo już zaczynam gonić w piętkę

    Dopisane
    Chwilowo mam dość, różne dziwne rzeczy można zrobić modyfikując opcje xorg.conf, bttv, xawtv, ale nijak fullscreen mi nie wychodzi. Po dodaniu do xorg.conf Option "overlay" "true" w xorg.log znajduję
    Kod:
    (WW) NVIDIA(0): Workstation overlay visuals are only available on Quadro FX
    (WW) NVIDIA(0):     cards
    (II) NVIDIA(0): Disabling overlays
    (==) NVIDIA(0): Enabling 32-bit ARGB GLX visuals.
    (--) Depth 24 pixmap format is 32 bpp
    Nie rozumiem, nie wiem dlaczego fullscreen działa na Etchu, a na Lennym nie...
    Ostatnio edytowane przez suncez ; 23.02.2009 o 23:55
    Regulamin Forum - lektura obowiązkowa Pytania - jak mądrze je zadawać vbcode - jak formatować tekst w postach Reputacja - jak używać przycisków reputacji

  6. #5
    Dołączył
    Mar 2007
    Wiek
    56
    Postów
    1,205
    Wątków
    104
    Downloads
    3
    Uploads
    0
    Siła Reputacji
    154
    Reputacja
    1950

    Odp: Nieprawidłowy fullscreen w xawtv

    Sprawa jest rozwiązana powiedzmy, połowicznie. Czemu? bo mam monitor panoramiczny 19" i xawtv wyświetla obraz 3/4 a powinien 16/9 ale nie każdy ma panoramę a po za tym mam możliwość sprzętowego przejścia na 16/9. A tu zawarta krótka sesja. Należy wyłączyć kamerę USB jeśli masz i podłączyć ją po wystartowaniu X-ów.
    Nadmienię że xawtv to także telegazeta, i masa programów dodatkowych zawartych w programach osobnych (różnie się one nazywają, common itp)
    xawtv-3.95-11mdv2009.0
    xawtv-misc-3.95-11mdv2009.0
    xawtv-common-3.95-11mdv2009.0
    xawtv-control-3.95-11mdv2009.0
    Odpalamy jako user

    [jan@localhost ~]$ xawtv -hwscan
    This is xawtv-3.95, running on Linux/i686 (2.6.27.14-desktop586-1mnb)
    looking for available devices
    port 355-386
    type : Xvideo, image scaler
    name : NV17 Video Texture

    port 387-418
    type : Xvideo, image scaler
    name : NV05 Video Blitter

    /dev/video0: OK [ -device /dev/video0 ]
    type : v4l2
    name : Leadtek Winfast 2000XP Expert
    flags: capture tuner

    [jan@localhost ~]$ xawtv -xvport 355
    This is xawtv-3.95, running on Linux/i686 (2.6.27.14-desktop586-1mnb)
    xinerama 0: 1440x900+0+0
    WARNING: No DGA direct video mode for this display.
    /dev/video0 [v4l2]: no overlay support
    v4l-conf had some trouble, trying to continue anyway
    .....Jan
    Nagradzam firmy produkujące sprzęt zgodny z Mandriva Linuks

    Dźwięk zawodowców Mandriva-linux-Xfce4-One-2009

  7. #6
    Avatar suncez
    suncez jest nieaktywny Super Moderator
    Mężczyzna
    Dystrybucja: Debian Mandriva
    Dołączył
    Aug 2004
    Postów
    3,195
    Wątków
    142
    Downloads
    11
    Uploads
    0
    Siła Reputacji
    281
    Reputacja
    3732

    Odp: Nieprawidłowy fullscreen w xawtv

    @Jan dziękuję za odpowiedź. Przejrzałem logi ze startu xorg w Etchu i Lennym, przedstawię efekty, wpierw jednak wyniki z podanych przez Ciebie poleceń.

    Lenny
    xawtv 3.95.dfsg.1-0
    xawtv-plugins 3.95.dfsg.1-0
    Kod:
    suncez@aisa:~$ xawtv -hwscan
    This is xawtv-3.95.dfsg.1, running on Linux/i686 (2.6.26-1-686)
    looking for available devices
    port 325-325                            [ -xvport 325 ]
        type : Xvideo, video overlay
        name : video4linux
    
    port 326-357
        type : Xvideo, image scaler
        name : NV17 Video Texture
    
    port 358-389
        type : Xvideo, image scaler
        name : NV05 Video Blitter
    
    /dev/video0: OK                         [ -device /dev/video0 ]
        type : v4l2
        name : BT878 video (Conceptronic CONTV
        flags: overlay capture tuner
    Kod:
    suncez@aisa:~$ xawtv -xvport 326
    This is xawtv-3.95.dfsg.1, running on Linux/i686 (2.6.26-1-686)
    xinerama 0: 1280x1024+0+0
    X Error of failed request:  XF86DGANoDirectVideoMode
      Major opcode of failed request:  136 (XFree86-DGA)
      Minor opcode of failed request:  1 (XF86DGAGetVideoLL)
      Serial number of failed request:  13
      Current serial number in output stream:  13
    v4l-conf had some trouble, trying to continue anyway
    W trybie pełnoekranowym dalej obraz w ramce.

    Etch
    xawtv 3.95.dfsg.1-1
    xawtv-plugins 3.95.dfsg.1-1
    Kod:
    [suncez@aisa~]$ xawtv -hwscan
    This is xawtv-3.95.dfsg.1, running on Linux/i686 (2.6.24-etchnhalf.1-686)
    looking for available devices
    port 245-245                            [ -xvport 245 ]
        type : Xvideo, video overlay
        name : video4linux
    
    port 246-246
        type : Xvideo, image scaler
        name : NV17 Video Overlay
    
    port 247-278
        type : Xvideo, image scaler
        name : NV17 Video Texture
    
    port 279-310
        type : Xvideo, image scaler
        name : NV05 Video Blitter
    
    port 311-311                            [ -xvport 311 ]
        type : Xvideo, video overlay
        name : NVIDIA Video Interface Port
    
    /dev/video0: OK                         [ -device /dev/video0 ]
        type : v4l2
        name : BT878 video (Conceptronic CONTV
        flags: overlay capture tuner
    Jest więcej danych w wyniku o
    Kod:
    port 246-246
        type : Xvideo, image scaler
        name : NV17 Video Overlay
    
    port 311-311                            [ -xvport 311 ]
        type : Xvideo, video overlay
        name : NVIDIA Video Interface Port
    Domyślnie wykorzystywany jest chyba xvport 245, na innych xawtv nie działa. Fullscreen oczywiście jest tu OK.

    Teraz efekty porównania Xorg.0.log
    Ta sama wersja sterowników (w Lenny są z łatką), ten sam xorg.conf. Prawie na samym dole wyszczególniłem różnice
    Etch
    Kod:
    X Window System Version 7.1.1
    Release Date: 12 May 2006
    X Protocol Version 11, Revision 0, Release 7.1.1
    (...)
    (==) RgbPath set to "/etc/X11/rgb"
    (...)
    (II) LoadModule: "bitmap"
    (II) Loading /usr/lib/xorg/modules/fonts/libbitmap.so
    (...)
    (II) LoadModule: "i2c"
    (II) Loading /usr/lib/xorg/modules/libi2c.so
    (...)
    (II) LoadModule: "ddc"
    (II) Loading /usr/lib/xorg/modules/libddc.so
    (...)
    
    (**) NVIDIA(0): Enabling RENDER acceleration
    (II) NVIDIA(0): NVIDIA GPU GeForce FX 5500 (NV34) at PCI:1:0:0 (GPU-0)
    (--) NVIDIA(0): Memory: 262144 kBytes
    (--) NVIDIA(0): VideoBIOS: 04.34.20.87.00
    (II) NVIDIA(0): Detected AGP rate: 4X
    (--) NVIDIA(0): Interlaced video modes are supported on this GPU
    (--) NVIDIA(0): Connected display device(s) on GeForce FX 5500 at PCI:1:0:0:
    (...)
    (--) NVIDIA(0):     option
    (==) NVIDIA(0): Disabling 32-bit ARGB GLX visuals.
    (...)
    (II) NVIDIA(0): v4l[/dev/video0]: using hw video scaling [YUY2].
    (II) Loading extension NV-CONTROL
    (==) RandR enabled
    (II) Initializing built-in extension MIT-SHM
    (II) Initializing built-in extension XInputExtension
    (II) Initializing built-in extension XTEST
    (II) Initializing built-in extension XKEYBOARD
    (II) Initializing built-in extension XC-APPGROUP
    (II) Initializing built-in extension SECURITY
    (II) Initializing built-in extension XINERAMA
    (II) Initializing built-in extension XFIXES
    (II) Initializing built-in extension XFree86-Bigfont
    (II) Initializing built-in extension RENDER
    (II) Initializing built-in extension RANDR
    (II) Initializing built-in extension COMPOSITE
    (II) Initializing built-in extension DAMAGE
    (II) Initializing built-in extension XEVIE
    (II) Initializing extension GLX
    Lenny
    Kod:
    X Window System Version 7.1.1
    Release Date: 12 May 2006
    X Protocol Version 11, Revision 0, Release 7.1.1
    (...)
    (==) RgbPath set to "/etc/X11/rgb"
    (...)
    (II) LoadModule: "bitmap"
    (II) Loading /usr/lib/xorg/modules/fonts/libbitmap.so
    (...)
    (II) LoadModule: "i2c"
    (II) Loading /usr/lib/xorg/modules/libi2c.so
    (...)
    (II) LoadModule: "ddc"
    (II) Loading /usr/lib/xorg/modules/libddc.so
    (...)
    
    (**) NVIDIA(0): Enabling RENDER acceleration
    (II) NVIDIA(0): NVIDIA GPU GeForce FX 5500 (NV34) at PCI:1:0:0 (GPU-0)
    (--) NVIDIA(0): Memory: 262144 kBytes
    (--) NVIDIA(0): VideoBIOS: 04.34.20.87.00
    (II) NVIDIA(0): Detected AGP rate: 4X
    (--) NVIDIA(0): Interlaced video modes are supported on this GPU
    (--) NVIDIA(0): Connected display device(s) on GeForce FX 5500 at PCI:1:0:0:
    (...)
    (--) NVIDIA(0):     option
    (==) NVIDIA(0): Disabling 32-bit ARGB GLX visuals.
    (...)
    (II) NVIDIA(0): v4l[/dev/video0]: using hw video scaling [YUY2].
    (II) Loading extension NV-CONTROL
    (==) RandR enabled
    (II) Initializing built-in extension MIT-SHM
    (II) Initializing built-in extension XInputExtension
    (II) Initializing built-in extension XTEST
    (II) Initializing built-in extension XKEYBOARD
    (II) Initializing built-in extension XC-APPGROUP
    (II) Initializing built-in extension SECURITY
    (II) Initializing built-in extension XINERAMA
    (II) Initializing built-in extension XFIXES
    (II) Initializing built-in extension XFree86-Bigfont
    (II) Initializing built-in extension RENDER
    (II) Initializing built-in extension RANDR
    (II) Initializing built-in extension COMPOSITE
    (II) Initializing built-in extension DAMAGE
    (II) Initializing built-in extension XEVIE
    (II) Initializing extension GLX
    Różnice

    W Etch jest
    Kod:
    (==) NVIDIA(0): Disabling 32-bit ARGB GLX visuals.
    (...)
    (II) NVIDIA(0): v4l[/dev/video0]: using hw video scaling [YUY2]
    W Lenny
    Kod:
    (==) NVIDIA(0): Enabling 32-bit ARGB GLX visuals
    Dodatkowo w Etch jest
    Kod:
    (==) RgbPath set to "/etc/X11/rgb"
    (...)
    (II) LoadModule: "bitmap"
    (II) Loading /usr/lib/xorg/modules/fonts/libbitmap.so
    A w Lenny dodatkowo jest
    Kod:
    (II) Initializing built-in extension XAccessControlExtension
    (...)
    (II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
    (II) NVIDIA(0):     enabled.
    Teraz zamierzam popracować nad opcjami w xorg.conf. Dużo informacji wyrzuca też xawtv uruchomione z debugowaniem.

    DZIAŁA FULLSCREEN W XAWTV !

    Doszedłem dzięki logom. W nowym xorg prawdopodobnie domyślnie jest dostępne rozszerzenie composite, a co za tym idzie są kłopoty z obsługą wideo. Do xorg.conf dodałem na początku
    Kod:
    Section "Extensions"
        Option "Composite" "false"
    EndSection
    I jak ręką odjął. Nie wiem czy tak samo będzie to działać jak naniosę poprawkę na oryginalnie generowany przy instalacji xorg.conf, jak nie to dopiszę co tam trzeba jeszcze. No i muszę ponowić instalację systemu, tak namieszałem że przeważnie nie mam dźwięku, a przecież nie ma pulse . Ale radocha, dwa dni długiego dłubania, ale działa !
    Ostatnio edytowane przez suncez ; 24.02.2009 o 18:48
    Regulamin Forum - lektura obowiązkowa Pytania - jak mądrze je zadawać vbcode - jak formatować tekst w postach Reputacja - jak używać przycisków reputacji

  8. #7
    Dołączył
    Mar 2007
    Wiek
    56
    Postów
    1,205
    Wątków
    104
    Downloads
    3
    Uploads
    0
    Siła Reputacji
    154
    Reputacja
    1950

    Odp: Nieprawidłowy fullscreen w xawtv

    No właśnie, w Xfce4 composite nie ma, ale za to zobacz:

    Section "Module"
    Disable "dri"
    Load "dbe" # Double-Buffering Extension
    Load "v4l" # Video for Linux
    Load "extmod"
    Load "type1"
    Load "freetype"
    Load "glx" # 3D layer
    EndSection
    Oraz

    Section "Device"
    Identifier "device1"
    VendorName "nVidia Corporation"
    BoardName "NVIDIA GeForce 6100 and later"
    Driver "nvidia"
    Option "DPMS"
    Option "DynamicTwinView" "false"
    Option "AddARGBGLXVisuals"
    EndSection
    I tyle, w xorg.conf a wszystko działa. Inna sprawa to bez problemu na fullscreen działa na prawdziwej konsoli bodajże fbtv albo motv, ale wyświetlane Menu jest fantastycznie zrobione, wszystkie dane, ustawienia są brane z .xawtv (chyba działa pod VESA, albo pod Framebuffer)....Jan





    Reputacja przyznana temu postowi
    Łącznie punktów reputacji: 143

    Komentarze:
     suncez  zgadza się   Dziękuję za pomoc !
    Ostatnio edytowane przez JanlllSobieski ; 24.02.2009 o 20:18
    Nagradzam firmy produkujące sprzęt zgodny z Mandriva Linuks

    Dźwięk zawodowców Mandriva-linux-Xfce4-One-2009

  9. #8
    Avatar suncez
    suncez jest nieaktywny Super Moderator
    Mężczyzna
    Dystrybucja: Debian Mandriva
    Dołączył
    Aug 2004
    Postów
    3,195
    Wątków
    142
    Downloads
    11
    Uploads
    0
    Siła Reputacji
    281
    Reputacja
    3732

    Odp: Nieprawidłowy fullscreen w xawtv

    Przy nowym xorg prawie nic nie ma w xorg.conf. Moduły, fonty i różne takie tam ładowane są automatycznie, nie trzeba żadnych wpisów. Za to jak chcemy coś wyłączyć, zabronić ładowania, to już musimy dodać odpowiedni wpis w xorg.conf. A w Debianie nie ma centrum sterowania systemem jak w Mandrivie. Najpierw zaskoczył mnie niemal pusty xorg.conf a potem to co on domyślnie robi. Tak wygląda xorg.conf w Lennym przy pierwszym uruchomieniu.
    Kod:
    Section "InputDevice"
    	Identifier	"Generic Keyboard"
    	Driver		"kbd"
    	Option		"XkbRules"	"xorg"
    	Option		"XkbModel"	"pc105"
    	Option		"XkbLayout"	"pl"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Configured Mouse"
    	Driver		"mouse"
    EndSection
    
    Section "Device"
    	Identifier	"Configured Video Device"
    EndSection
    
    Section "Monitor"
    	Identifier	"Configured Monitor"
    EndSection
    
    Section "Screen"
    	Identifier	"Default Screen"
    	Monitor		"Configured Monitor"
    EndSection
    Ostatnio edytowane przez suncez ; 25.02.2009 o 06:14
    Regulamin Forum - lektura obowiązkowa Pytania - jak mądrze je zadawać vbcode - jak formatować tekst w postach Reputacja - jak używać przycisków reputacji

  10. #9
    Dołączył
    Mar 2007
    Wiek
    56
    Postów
    1,205
    Wątków
    104
    Downloads
    3
    Uploads
    0
    Siła Reputacji
    154
    Reputacja
    1950

    Odp: Nieprawidłowy fullscreen w xawtv

    Ja powiedziałem sobie kiedyś że już dość, nie zmieniam nic. Pewnie fajnie to wszystko wygląda na początku, potem się wszystko wyrównuje i w końcu przychodzi taki moment że brakuje mi narzędzia, więc się po mandrivę - niestety. Bo całe życie spędzę na testowaniu różnych dystrybucji a niczego nie zrobię. Mam wielki problem co wybrać KDE, Gnome czy inne srodowisko, ale już nigdy nie przesiądę się na coś innego. Nie wieszają na nim co chcą, ja wybrnę tu z każdej sytuacji. Ostatni test to był SUSE 11.1, miałem dwa dni i jak widać jestem na MDV-Xfce4 i jestem zadowolony chociaż po instalacji pulpit idealny dla dziewczynek. Debiana miałem pół raza i już nigdy nie będę miał - ani razu. Powinien być jeden Linuks i kilka środowisk, a skupić się na tworzeniu natywnych programów, gier ewentualnie poprawek już gotowych programów. No i idzie to powoli. Trzeba pamiętać im więcej ludzi odchodzi do nowych dystrybucji to ten proces staje się wolniejszy, chociaz nie powiem powoduje to sporo nowych pomysłów ....Jan
    Nagradzam firmy produkujące sprzęt zgodny z Mandriva Linuks

    Dźwięk zawodowców Mandriva-linux-Xfce4-One-2009

Informacje o wątku

Users Browsing this Thread

Aktualnie 1 użytkownik(ów) przegląda ten wątek. (0 zarejestrowany(ch) oraz 1 gości)

Uprawnienia

  • Nie możesz zakładać nowych wątków
  • Nie możesz pisać wiadomości
  • Nie możesz dodawać załączników
  • Nie możesz edytować swoich postów
  •