Witaj Gościu, jeżeli to czytasz to znaczy że nie jesteś zarejestrowany/zalogowany. Kliknij by się zarejestrować. Rejestracja zajmie mniej niż 30 sekund , a dzięki temu zniknie Ci ten dymek oraz będziesz miał pełne możliwośći personalizacji forum do własnych potrzeb.
nVIdia drivers
Strona 1 z 2 12 OstatniOstatni
Pokaż wyniki od 1 do 10 z 11

Temat: nVIdia drivers

  1. #1
    Avatar Anonymous
    Anonymous Gość

    nVIdia drivers

    Zanim zadałem tu pytanie przeczytałem wszytko co udało mi się znaleźć w internecie na ten temat i problemu jak na razie nie udało mi się rozwiązać.
    Po zainstalowaniu sterowników nVidia (najnowszych o ile pamiętam 1.0-4496), zmodyfikowaniu XConfig-4 zgodnie z README i załadowaniu modułu nvidia w czasie wykoywania skryptu startx komputer się zawiesza w spoób uniemożliwiający zrobienie czego kolwiek oprócz "reset na obudowie komputera.

    Sterowników próbowałem zarówno na kernellu 2.4.21.-0.13mdk jak i zmienionym 2.4.22. Według logów wszytko jest ok. A jednak nie jest.
    Czy ktoś może mi pomóc?

  2. Panna Google
    Panna Google jest aktywna
    Avatar Panny Google

    Dołączył
    01-05-2004
    Skąd
    Internet
    Postów
    999
    Pochwał
    159

    Nie lubisz reklam? Zarejestrowani ich nie widzą! Rejestracja





  3. #2
    Dołączył
    Oct 2003
    Skąd
    Wrocław
    Wiek
    35
    Postów
    2,467
    Wątków
    38
    Downloads
    0
    Uploads
    0
    Siła Reputacji
    67
    Reputacja
    517

    Re: nVIdia drivers

    Zanim zadałem tu pytanie przeczytałem wszytko co udało mi się znaleźć w internecie na ten temat i problemu jak na razie nie udało mi się rozwiązać.
    Po zainstalowaniu sterowników nVidia (najnowszych o ile pamiętam 1.0-4496), zmodyfikowaniu XConfig-4 zgodnie z README i załadowaniu modułu nvidia w czasie wykoywania skryptu startx komputer się zawiesza w spoób uniemożliwiający zrobienie czego kolwiek oprócz "reset na obudowie komputera.

    Sterowników próbowałem zarówno na kernellu 2.4.21.-0.13mdk jak i zmienionym 2.4.22. Według logów wszytko jest ok. A jednak nie jest.
    Czy ktoś może mi pomóc?
    Heh, znam Twoją historię z pcol'a Ale jakoś nic mi do głowy nie przychodzi. Ale...Dwa tygodnie temu komilowałem jajko 2.4.22 i faktycznie efekt był mniej więcej taki jak opisywałeś. System padał, pozostawał twardy reset. Oczywiście na sterowniku nvidii. Ale w logach pojawiała się informacja, że nie można zincjować modułu. Problemem była na stałe wkompilowana obsługa /dev/agpart lub podobnie. Jeśli masz na stałe wkompilowane to musisz przekompilować jajko na nowo.

    Ale gdzieś mi przemknęło, że w plikach XF86config-(4) masz trochę jak dla mnie zbędnych informacji. U mnie poszczególne sekcej wyglądają tak:

    Section "Device"
    Identifier "device1"
    VendorName "nVidia Corporation"
    BoardName "NVIDIA GeForce2 DDR (generic)"
    Driver "nvidia"
    #Driver "nv"

    BusID "PCI:01:00:0"
    Option "NoLogo"
    Option "DPMS"
    EndSection


    Section "Module"
    Load "dbe" # Double-Buffering Extension
    Load "v4l" # Video for Linux
    Load "extmod"
    Load "type1"
    Load "freetype"
    Load "glx" # 3D layer
    EndSection

    Jeśli to nie pomoże to ja naprawdę nie mam pomysłu :/

  4. #3
    Avatar motto
    motto jest nieaktywny Jaskółka Europejska
    Mężczyzna
    • Platforma sprzętowa
      • Płyta Główna:
      • JetWay VB400
      • Procesor:
      • Athlon XP 2400
      • Karta Graficzna:
      • GeForce IV
      • Karta Dźwiękowa:
      • AC'97
      • Monitor:
      • Philips170B
      • Kernel:
      • zazwyczaj najnowszy...
    Dystrybucja: Debian GNU/Linux
    Dołączył
    Oct 2003
    Skąd
    Włocławek
    Wiek
    40
    Postów
    939
    Wątków
    101
    Downloads
    0
    Uploads
    0
    Siła Reputacji
    30
    Reputacja
    1
    Ehh z tym kompilowaniem jadra to też mam ekscesy, ale tu zapewne wynikajace z mojej niewiedzy, lub zbyt malej wiedzy. Wczytuje stary config do menuconfig i zmieniam tylko procesor na Athlona (nie wiem dlaczego jak sie system instaslowal to rozpoznał mojego Athlonka jako PIII). Kompiluje jajko robie wszytko jak trzeba jak w hawto i wszytko przebiega jak w w tych opisach z tym że na końcu okazuje się, iż nie mam DVD i dźwieku. Poszukam tego agpart czy co kolwiek to jest i jak rozumiem ma to isc jako moduł. Dziękuję już w tej chwili bo każdy pomysł jest dla mnie zbawienny (Daje mi odrobinę nadzieji na to że ureuchomie wszytko jak potrzeba).
    Co do pliku konfiguracyjnego to użyłeś słowa zbędnych, ale czy przeszkadzających? Ok ok zrobie jak najskromniej.

  5. #4
    Avatar Druciak
    Druciak jest nieaktywny Gold Member
    • Platforma sprzętowa
      • Płyta Główna:
      • Abit BX-133RAID
      • Procesor:
      • Pentium III (Coppermine)
      • Karta Graficzna:
      • GeForce
      • Karta Dźwiękowa:
      • Creative Labs SB Live!
      • Monitor:
      • iiyama
      • Kernel:
      • 2.6.16.23-1
    Dystrybucja: 2.0 PLD Linux (Ac)
    Dołączył
    May 2003
    Skąd
    Warszawa
    Postów
    1,537
    Wątków
    48
    Downloads
    0
    Uploads
    0
    Siła Reputacji
    37
    Reputacja
    71
    Ehh z tym kompilowaniem jadra to też mam ekscesy, ale tu zapewne wynikajace z mojej niewiedzy, lub zbyt malej wiedzy. Wczytuje stary config do menuconfig i zmieniam tylko procesor na Athlona (nie wiem dlaczego jak sie system instaslowal to rozpoznał mojego Athlonka jako PIII). Kompiluje jajko robie wszytko jak trzeba jak w hawto i wszytko przebiega jak w w tych opisach z tym że na końcu okazuje się, iż nie mam DVD i dźwieku. Poszukam tego agpart czy co kolwiek to jest i jak rozumiem ma to isc jako moduł. Dziękuję już w tej chwili bo każdy pomysł jest dla mnie zbawienny (Daje mi odrobinę nadzieji na to że ureuchomie wszytko jak potrzeba).
    Co do pliku konfiguracyjnego to użyłeś słowa zbędnych, ale czy przeszkadzających? Ok ok zrobie jak najskromniej.
    Robiles jak jest w HOWTO Zajrzyj do:
    Kod:
    [root@inferno root]# vi /usr/share/doc/kernel-source-2.4.21/README.kernel-sources
    Moze to ci jakos pomoze w konfiguracji kernela... tylko musisz wejsc do source swojego kernela... podpowiem, ze mozna zainstalowac pakiet kernel-source do pozniejszej kompilacji... Ech ten Mandrake
    Ps. nie wiem, ale wydaje mi sie, ze jak ja robielem make install to nawet nowy kernel dodal mi sie do lilo, wiec konfiguracje lilo.conf moglem sobie odpuscic.





  6. #5
    Avatar motto
    motto jest nieaktywny Jaskółka Europejska
    Mężczyzna
    • Platforma sprzętowa
      • Płyta Główna:
      • JetWay VB400
      • Procesor:
      • Athlon XP 2400
      • Karta Graficzna:
      • GeForce IV
      • Karta Dźwiękowa:
      • AC'97
      • Monitor:
      • Philips170B
      • Kernel:
      • zazwyczaj najnowszy...
    Dystrybucja: Debian GNU/Linux
    Dołączył
    Oct 2003
    Skąd
    Włocławek
    Wiek
    40
    Postów
    939
    Wątków
    101
    Downloads
    0
    Uploads
    0
    Siła Reputacji
    30
    Reputacja
    1
    Nie no kernel mi się instaluje, tylko potem ma dwa problemy, ginie mi DVD i dźwięk a robie konfig do nowego ze starego zmienijąc tylko prcesor na Athlon. Włąsnie mi zasugerowano, że pomoże

    Option "IgnoreDisplayDevices" "DFP, TV"

    w sekcji device. NO zobaczymy.

  7. #6
    Dołączył
    Oct 2003
    Skąd
    Wrocław
    Wiek
    35
    Postów
    2,467
    Wątków
    38
    Downloads
    0
    Uploads
    0
    Siła Reputacji
    67
    Reputacja
    517
    Nie no kernel mi się instaluje, tylko potem ma dwa problemy, ginie mi DVD i dźwięk a robie konfig do nowego ze starego zmienijąc tylko prcesor na Athlon. Włąsnie mi zasugerowano, że pomoże

    Option "IgnoreDisplayDevices" "DFP, TV"

    w sekcji device. NO zobaczymy.
    Z DVD nie pomoge. Co do dźwięku to musisz zainstalować sterowniki alsy. Waniliowy kernel ich nie ma, a mandrekowy jest łatany.

  8. #7
    Avatar Anonymous
    Anonymous Gość

    Re: nVIdia drivers

    Zanim zadałem tu pytanie przeczytałem wszytko co udało mi się znaleźć w internecie na ten temat i problemu jak na razie nie udało mi się rozwiązać.
    Po zainstalowaniu sterowników nVidia (najnowszych o ile pamiętam 1.0-4496), zmodyfikowaniu XConfig-4 zgodnie z README i załadowaniu modułu nvidia w czasie wykoywania skryptu startx komputer się zawiesza w spoób uniemożliwiający zrobienie czego kolwiek oprócz "reset na obudowie komputera.

    Sterowników próbowałem zarówno na kernellu 2.4.21.-0.13mdk jak i zmienionym 2.4.22. Według logów wszytko jest ok. A jednak nie jest.
    Czy ktoś może mi pomóc?
    spruboj skompilowac drivery z pakietow src.rpm. tylko tym sposobem osiagnalem sprawna akceleracje

  9. #8
    Dołączył
    Jul 2003
    Skąd
    Poznań
    Wiek
    34
    Postów
    1,740
    Wątków
    58
    Downloads
    0
    Uploads
    0
    Siła Reputacji
    42
    Reputacja
    141
    Jakiś czas temu, dałem na Forum opis instalacji sterowników nVidii. Możecie spróbować opisanym tam sposobem.
    This is your life and it's ending one minute at a time.

  10. #9
    Avatar Anonymous
    Anonymous Gość
    opis zaczerpniety z sieci (adresu juz nie pamietam :cry: ). tylko tym sposobem osiagnolem sprawne 3D pod mandrake
    ___
    Instalacja sterownika nvidia w Linux Mandrake 9.X.

    Najpierw należy pobrac 2 pliki:

    http://download.nvidia.com/XFree86_40/1.0-....0-3123.src.rpm
    http://download.nvidia.com/XFree86_40/1.0-....0-3123.src.rpm

    Teraz jako root należy zainstalować te źródła:
    rpm --rebuild NVIDIA_kernel-1.0-3123.src.rpm
    rpm --rebuild NVIDIA_GLX-1.0-3123.src.rpm

    Źródła instalują się w katalogu /usr/src/RPM/RPMS/i586
    Należy tam się udać i wydać takie komendy:
    rpm -Uvh NVIDIA_kernel-1.0-3123.i586.rpm
    rpm -Uvh NVIDIA_GLX-1.0.3123.i586.rpm

    Teraz jeszcze trzeba tylko zmienić wpis w pliku /etc/X11/XF86Config-4 (Section "Device")
    Driver "nv"
    na
    Driver "nvidia"

  11. #10
    Avatar Anonymous
    Anonymous Gość

    Re: nVIdia drivers

    Zanim zadałem tu pytanie przeczytałem wszytko co udało mi się znaleźć w internecie na ten temat i problemu jak na razie nie udało mi się rozwiązać.
    Po zainstalowaniu sterowników nVidia (najnowszych o ile pamiętam 1.0-4496), zmodyfikowaniu XConfig-4 zgodnie z README i załadowaniu modułu nvidia w czasie wykoywania skryptu startx komputer się zawiesza w spoób uniemożliwiający zrobienie czego kolwiek oprócz "reset na obudowie komputera.

    Sterowników próbowałem zarówno na kernellu 2.4.21.-0.13mdk jak i zmienionym 2.4.22. Według logów wszytko jest ok. A jednak nie jest.
    Czy ktoś może mi pomóc?
    http://www.nvnews.net/vbulletin/showthread...?threadid=20750

Strona 1 z 2 12 OstatniOstatni

Informacje o wątku

Users Browsing this Thread

Aktualnie 1 użytkownik(ów) przegląda ten wątek. (0 zarejestrowany(ch) oraz 1 gości)

Podobne wątki

  1. Sterowniki Do Karty Sieciowej Wifi
    By Bieniu in forum Instalacja Mandriva
    Odpowiedzi: 4
    Ostatni post / autor: 10.04.2005, 22:14
  2. Nie Moge Uruchomić Tunera Tv+radio
    By darek_p in forum Multimedia
    Odpowiedzi: 1
    Ostatni post / autor: 26.11.2004, 21:20
  3. nvidia - problemy...
    By krytyk in forum Sprzęt
    Odpowiedzi: 8
    Ostatni post / autor: 03.06.2004, 18:18

Members who have read this thread: 0

There are no members to list at the moment.

Uprawnienia

  • Nie możesz zakładać nowych wątków
  • Nie możesz pisać wiadomości
  • Nie możesz dodawać załączników
  • Nie możesz edytować swoich postów
  •