Witaj Gościu, jeżeli to czytasz to znaczy że nie jesteś zarejestrowany/zalogowany. Kliknij by się zarejestrować. Rejestracja zajmie mniej niż 30 sekund , a dzięki temu zniknie Ci ten dymek oraz będziesz miał pełne możliwośći personalizacji forum do własnych potrzeb.
LSTAT + RRDTOOL +Mandrake 9.0 dlugie i zawile
Pokaż wyniki od 1 do 10 z 10

Temat: LSTAT + RRDTOOL +Mandrake 9.0 dlugie i zawile

  1. #1
    Dołączył
    Nov 2003
    Postów
    22
    Wątków
    4
    Downloads
    0
    Uploads
    0
    Siła Reputacji
    0
    Reputacja
    1

    LSTAT + RRDTOOL +Mandrake 9.0 dlugie i zawile

    Witam moj pierwszy topic
    zainstalowalem sobie ostatnio Mandrake 9.0 na serwerze do dzielenia lacza...
    i wszystko grało ladnie i pieknie ogolnie... ale zachcialo mi sie lstata:-)
    No i tu jest problem:
    Lstat nie instaluje sie bo nie wykrywa rrdtool...
    rrdtool nie instaluje sie z rpm-a w wersjach najnowszych bo potrzebuje glibc ilestam... glibc nie instaluje sie bo potrzebuje script initscripts - a initstripts glibc - i sie kolko zamyka...) to pierwszy problem...
    drugi: zainstalowalem rrdtool w wersji starszej i niby wsio oki ale:
    lstat - dalej twierdzi ze tego nie ma... gdy "lekko poprawie" plik configure aby nie sprawdzal rrdtoola to przechodzi configure, make ale niestety make install wywala takie cus:

    [Sat Nov 29 03:46:16 2003] Mkgraph.pl: Can't load '/usr/lib/perl5/5.8.0/i386-linux-thread-multi/auto/RRDs/RRDs.so' for module RRDs: /usr/lib/perl5/5.8.0/i386-linux-thread-multi/auto/RRDs/RRDs.so: undefined symbol: PL_sv_undef at /usr/lib/perl5/5.8.0/i386-linux-thread-multi/DynaLoader.pm line 229.
    [Sat Nov 29 03:46:16 2003] Mkgraph.pl: at /usr/local/lstat/lib//Lstatobj.pm line 81
    [Sat Nov 29 03:46:16 2003] Mkgraph.pl: Compilation failed in require at /usr/local/lstat/lib//Lstatobj.pm line 81.
    [Sat Nov 29 03:46:16 2003] Mkgraph.pl: BEGIN failed--compilation aborted at /usr/local/lstat/lib//Lstatobj.pm line 81.
    [Sat Nov 29 03:46:16 2003] Mkgraph.pl: Compilation failed in require at /usr/local/lstat/bin//Mkgraph.pl line 9.
    [Sat Nov 29 03:46:16 2003] Mkgraph.pl: BEGIN failed--compilation aborted at /usr/local/lstat/bin//Mkgraph.pl line 9.
    make: *** [mkgraphs] Error 255

    jednym slowem: HELP
    Pozdrawiam
    Chris

    PS: acha, przyczyna pewnie jest w perl-u w wersji 5.8.0
    chcialem zamienic ja na 5.0.5 jak zalecane na rrdtool ale niestety pojawilo sie takie cus:
    [root@Serwer perl5.005_03]# make
    make: *** No rule to make target `<built-in>', needed by `miniperlmain.o'. Stop.
    [root@Serwer perl5.005_03]#
    (configure przeszlo bez problemow...) HELP - bladego pojecia nie mam o kompilacji wiec pewnie cos zmascilem...:/

    PS2: rddtool-a pliki sa w katalogach perla (perl -V) i plik RRDs.so' tez jest na swoim miejscu

    PS3: przegooglalem co popadlo, i przejrzalem listy dyskusyjne z rrdtoola, i big NIC

    PS4: mandrake 9.0 bez zadnych udziwnien i dodatkowych pakietow - czysty standardowo zainstalowany

  2. Panna Google
    Panna Google jest aktywna
    Avatar Panny Google

    Dołączył
    01-05-2004
    Skąd
    Internet
    Postów
    999
    Pochwał
    159

    Nie lubisz reklam? Zarejestrowani ich nie widzą! Rejestracja





  3. #2
    Avatar Druciak
    Druciak jest nieaktywny Gold Member
    • Platforma sprzętowa
      • Płyta Główna:
      • Abit BX-133RAID
      • Procesor:
      • Pentium III (Coppermine)
      • Karta Graficzna:
      • GeForce
      • Karta Dźwiękowa:
      • Creative Labs SB Live!
      • Monitor:
      • iiyama
      • Kernel:
      • 2.6.16.23-1
    Dystrybucja: 2.0 PLD Linux (Ac)
    Dołączył
    May 2003
    Skąd
    Warszawa
    Postów
    1,537
    Wątków
    48
    Downloads
    0
    Uploads
    0
    Siła Reputacji
    37
    Reputacja
    71
    A rrdtool instalowales
    Kod:
    rpm -ivh rrdtool-1.0.38-3mdk.i586.rpm
    czy
    Kod:
    urpmi rrdtool
    Jesli ten pierwszy i masz jakies problemy z zaleznosciami to moze uda ci sie zainstalowac tak:
    Kod:
    rpm -ivh rrdtool-1.0.38-3mdk.i586.rpm glibc-2.2.5-16mdk.i586.rpm initscripts-6.91-10mdk.i586.rpm
    Wydaje mi sie ze powinno pomoc.
    Oczywiscie wersje pakietow jakie podalem sa tylko przykladowe, wpisz te ktore sam masz

    Najlepiej jak bys wklejal na forum to co ci sie wyswietla na konsoli. To ulatwilo by diagnoze problemu. Wiadomo... lepiej sie wypowiadac o czyms co sie widzi





  4. #3
    Avatar Druciak
    Druciak jest nieaktywny Gold Member
    • Platforma sprzętowa
      • Płyta Główna:
      • Abit BX-133RAID
      • Procesor:
      • Pentium III (Coppermine)
      • Karta Graficzna:
      • GeForce
      • Karta Dźwiękowa:
      • Creative Labs SB Live!
      • Monitor:
      • iiyama
      • Kernel:
      • 2.6.16.23-1
    Dystrybucja: 2.0 PLD Linux (Ac)
    Dołączył
    May 2003
    Skąd
    Warszawa
    Postów
    1,537
    Wątków
    48
    Downloads
    0
    Uploads
    0
    Siła Reputacji
    37
    Reputacja
    71
    Proponuje takze, zrobic reinstalacje i zainstalowac nowsza wersje np. MDK 9.2 ;-)

    Ps. jesli nie uzywasz urpmi to poszukaj na forum i w internecie troche informacji na ten temat. To ulatwi ci instalowanie pakietow





  5. #4
    Dołączył
    Nov 2003
    Postów
    22
    Wątków
    4
    Downloads
    0
    Uploads
    0
    Siła Reputacji
    0
    Reputacja
    1
    [root@Serwer chris]# rpm -ivh glibc-2.3.2-15mdk.i586.rpm initscripts-7.06-11mdk.i586.rpm
    error: failed dependencies:
    initscripts < 6.91-18mdk conflicts with glibc-2.3.2-15mdk
    ifplugd is needed by initscripts-7.06-11mdk
    [root@Serwer chris]# urpmi
    everything already installed
    [root@Serwer chris]# urpmi initscripts-7.06-11mdk.i586.rpm
    installing ./initscripts-7.06-11mdk.i586.rpm

    Installation failed:
    ifplugd is needed by initscripts-7.06-11mdk
    libc.so.6(GLIBC_2.3) is needed by initscripts-7.06-11mdk
    [root@Serwer chris]#

    I tu sie zapetla bo bez jednego drugiego nie moge zainstalowac, to raz
    dwa rrdtool jak juz pisalem zainstalowalo sie i wrzucilo swoje moduly ale dalej kicha:

    Sat Nov 29 03:46:16 2003] Mkgraph.pl: Can't load '/usr/lib/perl5/5.8.0/i386-linux-thread-multi/auto/RRDs/RRDs.so' for module RRDs: /usr/lib/perl5/5.8.0/i386-linux-thread-multi/auto/RRDs/RRDs.so: undefined symbol: PL_sv_undef at /usr/lib/perl5/5.8.0/i386-linux-thread-multi/DynaLoader.pm line 229.

    zamienilem plik rrds.so na wersje od znajomego i zrobilo sie z tego cos takiego:

    make install ->(lstat)
    (......)
    <pre>Can't load '/usr/lib/perl5/5.8.0/RRDs.so' for module RRDs: /lib/i686/libc.so.6: version `GLIBC_2.3' not found (required by /usr/lib/perl5/5.8.0/RRDs.so) at /usr/lib/perl5/5.8.0/i386-linux-thread-multi/DynaLoader.pm line 229.
    at /usr/local/lstat/lib//Lstatobj.pm line 81

    czyli teraz znowu glibc 2.3 conajmniej potrzebuje - i znowu kicha


    mysle ze zdobycie initscripts-6.91-18mdk w tej dokladnie wersji rozwiazalo by odrobinke problemow.... ale takiej wersji nie ma... a wersja z ciut wyzszym numerkiem juz glibc 2.3 wymaga ...:[

    Pozdrawiam Chris
    PS przejscie na nowszego mandrake na razie nie wchodzi w rachube ze wzgledu na bezprzewodowke....:/

  6. #5
    Dołączył
    Nov 2003
    Postów
    22
    Wątków
    4
    Downloads
    0
    Uploads
    0
    Siła Reputacji
    0
    Reputacja
    1
    heh, po kolejnych 6 h mieszania... RUSZYLO kij wie czemu...(instalowalem deinstalowalem... mieszalem instalowalem deinstalowalem i znowu mieszalem... az wkoncu zaskoczylo)
    POZDRAWIAM
    Chris

    PS
    dalej bede dzwieczny za wyjasnienie jak zrobic upgrade glibc i initscripts jesli sa to osobne pakiety i jeden wymaga drugiego zeby sie zainstalowac ( a oba sa juz zainstalowane tylko w starszych wersjach - zbyt niskich)

    EDITED:
    ;-( wysypuje sie ... PLEASE niech mi ktos podesle plik RRDs.so majacy perla w wersji 5.8.0 i mandrake 9.0 na maila: chrisb99@wp.pl
    DZIEKI

  7. #6
    Avatar Druciak
    Druciak jest nieaktywny Gold Member
    • Platforma sprzętowa
      • Płyta Główna:
      • Abit BX-133RAID
      • Procesor:
      • Pentium III (Coppermine)
      • Karta Graficzna:
      • GeForce
      • Karta Dźwiękowa:
      • Creative Labs SB Live!
      • Monitor:
      • iiyama
      • Kernel:
      • 2.6.16.23-1
    Dystrybucja: 2.0 PLD Linux (Ac)
    Dołączył
    May 2003
    Skąd
    Warszawa
    Postów
    1,537
    Wątków
    48
    Downloads
    0
    Uploads
    0
    Siła Reputacji
    37
    Reputacja
    71
    [root@Serwer chris]# rpm -ivh glibc-2.3.2-15mdk.i586.rpm initscripts-7.06-11mdk.i586.rpm
    error: failed dependencies:
    initscripts < 6.91-18mdk conflicts with glibc-2.3.2-15mdk
    ifplugd is needed by initscripts-7.06-11mdk
    [root@Serwer chris]# urpmi
    everything already installed
    [root@Serwer chris]# urpmi initscripts-7.06-11mdk.i586.rpm
    installing ./initscripts-7.06-11mdk.i586.rpm

    Installation failed:
    ifplugd is needed by initscripts-7.06-11mdk
    libc.so.6(GLIBC_2.3) is needed by initscripts-7.06-11mdk
    [root@Serwer chris]#
    Hmm...
    A moze
    Kod:
    rpm -Uvh glibc-2.3.2-15mdk.i586.rpm initscripts-7.06-11mdk.i586.rpm
    A co pokazuje
    Kod:
    rpm -qa | grep glibc
    
    rpm -qa | grep initscripts
    PS przejscie na nowszego mandrake na razie nie wchodzi w rachube ze wzgledu na bezprzewodowke....:/
    Czyli czemu Na MDK 9.1/9.2 nie bedzie dzialac
    Czy uzytkownicy sie beda skarzyc ze im net nie dziala





  8. #7
    Dołączył
    Nov 2003
    Postów
    22
    Wątków
    4
    Downloads
    0
    Uploads
    0
    Siła Reputacji
    0
    Reputacja
    1
    dobra, problem sie rozwiazal.... spsulem apacha i perla (juz nie startuja :roll: ) wiec zaciagam i instaluje 9.1 :twisted: mam tylko nadzieje ze sobie z bezprzewodowka pod 9.1 poradze... :?
    Pozdrawiam
    Chris

  9. #8
    Avatar Druciak
    Druciak jest nieaktywny Gold Member
    • Platforma sprzętowa
      • Płyta Główna:
      • Abit BX-133RAID
      • Procesor:
      • Pentium III (Coppermine)
      • Karta Graficzna:
      • GeForce
      • Karta Dźwiękowa:
      • Creative Labs SB Live!
      • Monitor:
      • iiyama
      • Kernel:
      • 2.6.16.23-1
    Dystrybucja: 2.0 PLD Linux (Ac)
    Dołączył
    May 2003
    Skąd
    Warszawa
    Postów
    1,537
    Wątków
    48
    Downloads
    0
    Uploads
    0
    Siła Reputacji
    37
    Reputacja
    71
    Moze powinienes 9.2 sciagac
    Zawsze dluzej beda uaktualnienia wychodzic

    Ps. perl mi nigdy nie startowal... Moze mam cos zle ;-)





  10. #9
    Dołączył
    Nov 2003
    Postów
    22
    Wątków
    4
    Downloads
    0
    Uploads
    0
    Siła Reputacji
    0
    Reputacja
    1
    moze i tak. ale pod 9.2 nie mam dostepu do binarnej wersji sterownikow do tej zakichanej bezprzewodowki a pod 9.1 je mam

  11. #10
    Avatar Anonymous
    Anonymous Gość
    A mi sie wszystko niby zainstalowalo ale po wejsciu na http://mojeIP/lstat/lstat.cgi pokazuje mi cos takiego:

    Can't locate Lstatobj.pm in @INC (@INC contains: /usr/lib/perl5/5.6.1/i386-linux/lstat/ /usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0 /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl .) at /var/www/cgi-bin/lstat/lstat.cgi line 10.
    BEGIN failed--compilation aborted at /var/www/cgi-bin/lstat/lstat.cgi line 10.

    Czy to oznacza ze czegos nie zainstalowalem? czy sie cos zle zainstalowalo?

    Mam Mandrake 9.1

Informacje o wątku

Users Browsing this Thread

Aktualnie 1 użytkownik(ów) przegląda ten wątek. (0 zarejestrowany(ch) oraz 1 gości)

Podobne wątki

  1. Odpowiedzi: 1
    Ostatni post / autor: 10.07.2004, 03:53

Uprawnienia

  • Nie możesz zakładać nowych wątków
  • Nie możesz pisać wiadomości
  • Nie możesz dodawać załączników
  • Nie możesz edytować swoich postów
  •