Witaj Gościu, jeżeli to czytasz to znaczy że nie jesteś zarejestrowany/zalogowany. Kliknij by się zarejestrować. Rejestracja zajmie mniej niż 30 sekund , a dzięki temu zniknie Ci ten dymek oraz będziesz miał pełne możliwośći personalizacji forum do własnych potrzeb.
Gdzie szukać przyczyny? (dwa dni bez snu...)
Pokaż wyniki od 1 do 4 z 4

Temat: Gdzie szukać przyczyny? (dwa dni bez snu...)

  1. #1
    Avatar motto
    motto jest nieaktywny Jaskółka Europejska
    Mężczyzna
    • Platforma sprzętowa
      • Płyta Główna:
      • JetWay VB400
      • Procesor:
      • Athlon XP 2400
      • Karta Graficzna:
      • GeForce IV
      • Karta Dźwiękowa:
      • AC'97
      • Monitor:
      • Philips170B
      • Kernel:
      • zazwyczaj najnowszy...
    Dystrybucja: Debian GNU/Linux
    Dołączył
    Oct 2003
    Skąd
    Włocławek
    Wiek
    40
    Postów
    939
    Wątków
    101
    Downloads
    0
    Uploads
    0
    Siła Reputacji
    30
    Reputacja
    1

    Gdzie szukać przyczyny? (dwa dni bez snu...)

    Ustaliłem już ponad wszelką wątpliwość, że wszytko robię dobrze. (przypomnę sprawa dotyczy nieszczęsnych driver'ów nvidia).

    Dla pewności że moje kombinacje z jajekiem nie mają nic z tym współnego powróciłem do kernela 2.4.22-10mdk przekompilowanego tylko i wyłącznie po zmianie procesora na Athlon/Duron, resztę opcii pozostawiając bez jak w pliku /boot/config-2.4.22-10mdk.

    Instaluję drivery ściągnięte ze strony nvidii (http://www.nvidia.com/object/linux_d..._1.0-4496.html)
    przy pomocy polecenia:
    "$ sh ./NVIDIA-Linux-x86-1.0-4496-pkg2.run -n --kernel-name=2.4.22-10mdk --kernel-include-path=/usr/src/linux/include -a". Drivery się instalują poprawnie, a przynajniej to wynika z końcowego komunikatu, czy też pliku log.

    Modyfikuję plik XF86Config-4 zgodnier z opisem w README. (ftp://download.nvidia.com/XFree86/Li...496/README.txt)

    *
    (...)
    Section "Module"
    Load "dbe" # Double-Buffering Extension
    Load "v4l" # Video for Linux
    Load "extmod"
    Load "type1"
    Load "freetype"
    ==>>Load "glx" # 3D layer
    EndSection
    (...)
    Section "Device"
    Identifier "device1"
    VendorName "nVidia Corporation"
    BoardName "NVIDIA GeForce4 (generic)"
    ==>>Driver "nvidia"
    #Option "IgnoreDisplayDevices" "DFP, TV"
    Option "DPMS"
    ==>>BusID "PCI:1:0:0"
    EndSection
    (...)
    *

    Sprawdzam $modprobe "$ nvidia",
    po czy, dla pewności "$ lsmod | grep nvidia".
    Wszytko w porządku. No więc wszytko jest ok.
    Po wypisuaniu polecnienia "$ startx" powinienm zobaczyc ładne logo nvidia.
    A tym czasem coś jest nie tak, ale gdzie szukać przczyny?

    Plik .../XFree86.0.log raz sie tworzy raz nie, kiedy się tworzy wygląda mniej więcej tak http://www.satfilm.net.pl/~motto77/nvidia/...a/XFree86.0.log

    Sprawa jest o tyle ciekawa, że przy Mdk 9.1 wszytko mi działało i po początkowych problemach instalowanie sterowników nvidii nie sprawiało mi już żadnych problemów.

    Po dwóch dniach walki bez snu poddaje się, przynajmniej na dziś, mam dość.
    Przeczytałem nie zliczoną ilość dokumentów w internecie, kilkanaście razy kompilowałem różne jądra i instalowałem na nich różne sterowniki i te wymienione i rpm'y. Kilkanaście razy (kiedy utworzył się XFree86.0.log porównywałme go z jego odpowiednikiem z Mdk91, kiedy to wszytko chodziło).
    Instalowałem po raz drugi Mdk 9.2 tym razem z formatem "./", żeby uzyskać
    pewność, że nałożenie wersji 9.2 na 9.1 nie było błędem. Ściągnąlem wsytkie możliwe aktualizacje (w sumie przeszło 450 MB o ile pamiętam). Włożyłem do siebie identyczną kartę graficzną od sąsiada, żeby wykluczyć awarię karty graficznej i zrobiłem jeszcze wiele innych rzeczy o których już po prostu nie che mi się pisać. Kilku rzeczy jestem pewny: sprzęt jest sprawy, BIOS dobrze ustawiony, steroniki instalowane poprawnie. Nie wiem tylko dlaczego nie działa. Ide spać, nie budzić mnie przed wielkanocą .
    Pozdrawiam

  2. Panna Google
    Panna Google jest aktywna
    Avatar Panny Google

    Dołączył
    01-05-2004
    Skąd
    Internet
    Postów
    999
    Pochwał
    159

    Nie lubisz reklam? Zarejestrowani ich nie widzą! Rejestracja





  3. #2
    Dołączył
    Dec 2003
    Skąd
    z wariatkowa
    Postów
    317
    Wątków
    38
    Downloads
    0
    Uploads
    0
    Siła Reputacji
    29
    Reputacja
    1
    Jestem strasznie zielony w linuksie ale napiszę co ja zrobiłem

    1. Uruchomiłem program NVIDIA-Linux-x86-1.0-4496-pkg2-run
    bez żadnych parametrów
    2. zapytał się o jakiś kernel interface a potem napisał że sam musi skompitlować co uczynił
    3. zmieniłem 1 wpis w XFree86-4 ("nv"->"nvidia")

    to wszystko

    Pozdrawiam
    Slig

  4. #3
    Dołączył
    Oct 2003
    Skąd
    Wrocław
    Wiek
    35
    Postów
    2,467
    Wątków
    38
    Downloads
    0
    Uploads
    0
    Siła Reputacji
    67
    Reputacja
    517
    A nie zachowałeś konfigu X'ów z 9.1? To by CI bardzo ułatwilło sprawę.Skoro w 9.1 działało to w 9.2 też powinno.

  5. #4
    Avatar motto
    motto jest nieaktywny Jaskółka Europejska
    Mężczyzna
    • Platforma sprzętowa
      • Płyta Główna:
      • JetWay VB400
      • Procesor:
      • Athlon XP 2400
      • Karta Graficzna:
      • GeForce IV
      • Karta Dźwiękowa:
      • AC'97
      • Monitor:
      • Philips170B
      • Kernel:
      • zazwyczaj najnowszy...
    Dystrybucja: Debian GNU/Linux
    Dołączył
    Oct 2003
    Skąd
    Włocławek
    Wiek
    40
    Postów
    939
    Wątków
    101
    Downloads
    0
    Uploads
    0
    Siła Reputacji
    30
    Reputacja
    1
    Jestem strasznie zielony w linuksie ale napiszę co ja zrobiłem

    1. Uruchomiłem program NVIDIA-Linux-x86-1.0-4496-pkg2-run
    bez żadnych parametrów
    2. zapytał się o jakiś kernel interface a potem napisał że sam musi skompitlować co uczynił
    3. zmieniłem 1 wpis w XFree86-4 ("nv"->"nvidia")

    to wszystko

    Pozdrawiam
    Slig
    Ta metodę też nie działa tak za pierwszym razem robiłem.
    I zachowałem konfiga z 9.1 i na nim tez nie działa.

Informacje o wątku

Users Browsing this Thread

Aktualnie 1 użytkownik(ów) przegląda ten wątek. (0 zarejestrowany(ch) oraz 1 gości)

Podobne wątki

  1. Mldonkey - Gdzie Jest Incoming?
    By vince-mystery in forum Oprogramowanie
    Odpowiedzi: 6
    Ostatni post / autor: 15.05.2005, 22:51
  2. Opis Dvd::rip, Gdzie Szukać?
    By LukasDvd in forum Multimedia
    Odpowiedzi: 4
    Ostatni post / autor: 20.02.2005, 02:40
  3. Konsola gdzie??
    By Anonymous in forum Oprogramowanie
    Odpowiedzi: 3
    Ostatni post / autor: 15.04.2004, 10:23
  4. Gdzie szukać nowych "MOTYW-ów" do Mandrake KDE
    By martocho in forum Oprogramowanie
    Odpowiedzi: 3
    Ostatni post / autor: 09.03.2004, 09:55
  5. Gdzie kupic mandrake 9.2 Box
    By Dataway in forum Instalacja Mandriva
    Odpowiedzi: 3
    Ostatni post / autor: 17.10.2003, 21:09

Uprawnienia

  • Nie możesz zakładać nowych wątków
  • Nie możesz pisać wiadomości
  • Nie możesz dodawać załączników
  • Nie możesz edytować swoich postów
  •